Author Message

Mallachy

Rank 0
Mallachy
Joined
22 Dec 2009
Posts
156
Location
Philippines
PostedMar 28, 2010 1:51 pm

Solution for Italic Font on WINDOWS 7. >.<

Open, open, open.
Original: http://forums.aeriagames.com/viewtopic.php?t=613555

But I can't follow the steps properly on W7..

Anyhow, here's a solution.
I used the font Calibri here. It makes stuff easier. And I can't find another way to do this..sorry. ><

1.) Open Windows' Fonts folder. [You could just type "fonts" on search when you open up the Start Menu and hit enter.]
2.) Open Grand Fantasia folder and open font.ini.
3.) With your Grand Fantasia folder still open, open up the "font" folder.
4.) Bring up the Windows Fonts folder and double-click on Calibri or any other Font. A Calibri sub-folder will pop up and copy one of those to Grand Fantasia's own font folder. You could keep or delete the other font there. You only have to directly copy the font if what you chose from Windows Fonts doesn't have font sub-types. Neutral [In my case, I used Calbri Bold.]
5.) Switch to the .ini file and replace all (if you want everything to be written in the same font), with the font title. In Calibri's case, I just input Calibri. No space after each '=' sign.
6.) Copy the file name of the font you copied to GF's font folder.In here, replace the font name to that. [Again, in Calibri's case, 'calibrib' is the file name so I replaced the original font's name with that.]


Here's what it looks like now:

[FontOption]
// 字型設定
// 遊戲系統英文字型
DefEnglishFont=Calibri
DefEnglishFontSize=8
// 遊戲系統主要字型
DefMainFont=Calibri
DefMainFontSize=8
// 泡泡聊天字型
BubbleFont=Calibri
BubbleFontSize=8
// 區域抬頭顯示字型
HintFont=.\font\calibrib.ttf
HintFontSize=18
// 名條字型
HIDFont=Calibri
HIDFontSize=8

Here's another using Georgia:
[FontOption]
// 字型設定
// 遊戲系統英文字型
DefEnglishFont=Georgia
DefEnglishFontSize=8
// 遊戲系統主要字型
DefMainFont=Georgia
DefMainFontSize=8
// 泡泡聊天字型
BubbleFont=Georgia
BubbleFontSize=8
// 區域抬頭顯示字型
HintFont=.\font\Georgia.ttf
HintFontSize=18
// 名條字型
HIDFont=Georgia
HIDFontSize=8

Replace the info in the original font.ini file with this and just copy georgia regular into GF's font folder..


Mod Edit: Stickied
Advertisement

xdegenerate

Rank 0
Joined
25 Oct 2009
Posts
103
Location
United States
PostedMay 11, 2010 6:23 pm
That will have to suffice until an update can resolve the issue.

But after each update, the font size and type resets to default. There should be an in-game option to deal with fonts and save the settings.

luigi108

Rank 0
Joined
15 Jan 2010
Posts
5
Location
United States
PostedFeb 25, 2011 12:52 am

how u do this

[FontOption]
// 字型設定
// 遊戲系統英文字型
DefEnglishFont=Calibri
DefEnglishFontSize=8
// 遊戲系統主要字型
DefMainFont=Calibri
DefMainFontSize=8
// 泡泡聊天字型
BubbleFont=Calibri
BubbleFontSize=8
// 區域抬頭顯示字型
HintFont=.\font\calibrib.ttf
HintFontSize=18
// 名條字型
HIDFont=Calibri
HIDFontSize=8

omninick

Rank 0
omninick
Joined
17 Jun 2007
Posts
11
Location
Milton Keynes United Kingdom
PostedApr 11, 2011 1:18 am

Font Messup

You shouldn't change the font out of italic to that because you've booted up the script delve pattern which makes all text in game like that. Unfortunately, you'll just have to wait for the next update. If it doesn't change in the next update than your patches are leaked and you will have to reinstall the game. Hope this helps Very Happy

- Nick -

xXEliteChrisXx

Rank 0
xXEliteChrisXx
Joined
20 Oct 2010
Posts
7
Location
Norwich United Kingdom
PostedApr 15, 2011 11:00 am

i have same problem

I have the same problem but this didnt help what else can i do i have tryed to uninstall and re-install aswell >_<

Detrolord

Rank 0
Detrolord
Joined
19 Jun 2010
Posts
154
Location
Norwalk United States
PostedJul 13, 2013 6:02 am

Re: i have same problem

xXEliteChrisXx wrote:
I have the same problem but this didnt help what else can i do i have tryed to uninstall and re-install aswell >_<  

Hmm it should be in the control panel in Windows the system font folder alsoyou might wanna update your system and download a basic font style and make it a default in your computer
Youtube or Google
How to change the system default font

xTsuki

Rank 2
xTsuki
Joined
12 Dec 2009
Posts
549
Location
Germany
PostedJul 13, 2013 6:09 am

Re: i have same problem

Detrolord wrote:
xXEliteChrisXx wrote:
I have the same problem but this didnt help what else can i do i have tryed to uninstall and re-install aswell >_<  

Hmm it should be in the control panel in Windows the system font folder alsoyou might wanna update your system and download a basic font style and make it a default in your computer
Youtube or Google
How to change the system default font  


It's nice seeing you wanting to help others out, but the last post was in April 2011. I am sure they have resolved their issue already or are not checking back.
Display posts from previous:   Sort by: