Author Message

down1234

Rank 0
Joined
16 Feb 2010
Posts
17
Location
Canada
PostedAug 27, 2011 3:49 pm

[Bug?] Warlock Skill: Plague Carrier

seems bugged to me?
Seems like no matter what lvl plague carrier is.. the parasite is still lv1?

No one else seems to have reported this on forums, or im blind and fail@search
Advertisement

Ryuucat

Rank 1
Ryuucat
Joined
02 Apr 2011
Posts
307
Location
Alberta, Canada
PostedAug 28, 2011 2:58 pm

Re: [Bug?] Warlock Skill: Plague Carrier

seems bugged to me?
down1234 wrote:
Seems like no matter what lvl plague carrier is.. the parasite is still lv1?

No one else seems to have reported this on forums, or im blind and fail@search  


Unfortunately I leveled my Plague Carrier to full without even checking each level's effects.

We can probably do a comparison, though.

At level 50, my Plague Carrier does 67 damage per second per stack.

I have to agree, this seems a little weak for a level 50 skill that's maxed out.

down1234

Rank 0
Joined
16 Feb 2010
Posts
17
Location
Canada
PostedAug 29, 2011 10:58 am
hmm.. that is strage
mine is 39 and mine do 44 dps per stack


so i guess the dmg does go up, but its no where near as strong as parasite


seems to be workin as intented with a misleading tooltip then

KristalTear

Rank 0
KristalTear
Joined
10 Aug 2009
Posts
24
Location
Spain
PostedSep 05, 2011 3:21 pm
at least u guys can get it to work!!!!!!!! I dont know what more to do to make it even work.. It says to plant a Dark parasite, so I do, click on plague carrier and "i cannot use this on target" -.-" wtf??? what am i doing wrooong >.<!!!
Display posts from previous:   Sort by: