Author Message

Belakar

Rank 0
Joined
28 Dec 2010
Posts
45
Location
United States
PostedNov 30, 2012 8:44 am

Master Fortification Inscription 4 failing?

and apparently Aeria is giving no refunds...
Issue: Had a guild mate say they used an MFI4 on a piece of gear to +15 it. It failed, item lost. He put in a RT. Got a response back from Aeria, to the affect of, so sorry so sad that our as advertised 100% +15 thingy doesn't work... but no item return.

Now everything above is hearsay. I have no way of proving the veracity of said guild mate's claims. The reason behind my post, is to find out if anyone else has had this issue. If so, has Aeria returned the broken item?
Advertisement

Zen_Hikari

Rank 2
Zen_Hikari
Joined
30 Jan 2011
Posts
458
Location
United States
PostedNov 30, 2012 8:50 am
I dont believe something like this has happpend before. But if u want your item back feel free to check out this OP link

http://www.aeriagames.com/forums/en/viewtopic.php?t=1799421

Posted By Aeria Mobile

iBambi

Rank 5
iBambi
Joined
05 Oct 2010
Posts
4849
Location
Whale hunting in Norway
PostedNov 30, 2012 9:07 am
A few people have claimed their 100% items or SS3 didn't work and that their item disappeared as a result of this claimed bug, but in most.. probably all of these cases, the user have made a mistake. I doubt there's any bug with the fortification items, just players making mistakes.

Belakar

Rank 0
Joined
28 Dec 2010
Posts
45
Location
United States
PostedNov 30, 2012 2:16 pm
iBambi wrote:
A few people have claimed their 100% items or SS3 didn't work and that their item disappeared as a result of this claimed bug, but in most.. probably all of these cases, the user have made a mistake. I doubt there's any bug with the fortification items, just players making mistakes.  


Thanks... I appreciate it...

LaFeAir

Rank 0
LaFeAir
Joined
03 Jan 2011
Posts
6
Location
barnesville United States
PostedDec 04, 2012 11:49 pm
it is very possible that a mistake could have been made without it being realized. for example i made a mistake fortifying a weapon to +11, i attempted to place a MFI 3 in the clover slot while the MFI 2 was still there. doing so the MFI 3 did not set in the clover spot and i lost my weapon as the result. at first i thought there was something messed up with the fortification but upon further inspection i noticed the MFI 2 was in the clover spot. your friend may have done something similar or he may have used a MFI 3 instead of a MFI 4 cause they look the same, so best advice to give is to just make sure you pay attention to what you place in respective areas or you may lose your item. I for one would like to see the MFI 3-7 look differently because it could confuse people

Rubicante1/80 Templar. in nomine patri et fili spiritus sancti

evilishan

Rank 3
evilishan
Joined
10 Apr 2011
Posts
1196
Location
Sydney Australia
PostedDec 05, 2012 9:58 am
I personally have not had this issue as of yet.

Do I think it might be possible? Sorry, currently I don't think it is.
I have had one occasion where I misplaced my Sage Stone and I didn't put it into the slot and lost an item (a spotless +14 King of the Battlefield). I was upset for a few days and then moved on.

Display posts from previous:   Sort by: